Item Outage: Argos eGift Cards - 7/2/2019
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted Jul 03, 2019 - 07:56 PDT
Identified
Orders for Argos eGift Cards are currently failing through our supplier. We will post an update when this reward is once again available.
Posted Jul 02, 2019 - 08:17 PDT
This incident affected: Item.