Item Outage: Amazon Pay Gift Card India ₹1000 - 10/16/19
Incident Report for Tango Card
Resolved
This outage has been resolved.
Posted Oct 18, 2019 - 08:13 PDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 18, 2019 - 08:13 PDT
Identified
We are experiencing and outage on Amazon Pay Gift Card India ₹1000. The affected UTID is UTID:U705529

More is on order, and we expect to have it back in stock soon.
Posted Oct 16, 2019 - 02:24 PDT
This incident affected: Item.