Item Outage - iTunes Canada eGift Card $10.00 - UTID U323615
Incident Report for Tango Card
Resolved
This outage has been resolved.
Posted Jul 18, 2019 - 13:23 PDT
Identified
We are experiencing an outage on iTunes Canada eGift Card $10.00 - UTID U323615. We are unable to provide an estimate when this will be back in stock, as our vendor is unable to fulfill orders for this card, at this time.
Posted Jun 23, 2019 - 03:23 PDT
This incident affected: Item.