Visa and MasterCard products - Planned maintenance - 7/14/2019
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted Jul 15, 2019 - 10:25 PDT
Identified
Our supplier for all Visa and Mastercard products is performing a planned maintenance on their system on July 14th, 2019 from 12:01 - 2:00 AM CST.
During this time you may experience some or all orders for Visa and Mastercard products to fail.

Thank you for your understanding.
Posted Jul 12, 2019 - 16:42 PDT
This incident affected: Item.