Item Outage - Zooplus.de Gift Card €5 - 10/13/20
Incident Report for Tango Card
Resolved
This outage has been resolved.
Posted Oct 14, 2020 - 11:04 PDT
Identified
Zooplus.de Gift Card €5 is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U418580
Posted Oct 13, 2020 - 09:57 PDT
This incident affected: Item.