Item Outage - OVS Gift Card € 10
Incident Report for Tango Card
Resolved
This outage has been resolved.
Posted 25 days ago. Sep 27, 2019 - 12:15 PDT
Identified
We are experiencing and outage on OVS Gift Card € 10. The affected UTID is UTID:U616488.

We have more of this item on order.
Posted 26 days ago. Sep 26, 2019 - 13:45 PDT
This incident affected: Item.