Item Outage - BookMyShow Gift Voucher ₹500 - 8/26/2020
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted Nov 11, 2020 - 16:30 PST
Identified
BookMyShow Gift Voucher ₹500 is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U426325
Posted Aug 26, 2020 - 14:38 PDT
This incident affected: Item.