Item Outage: Zalora Gift Card S$25
Incident Report for Tango Card
Resolved
This outage has been resolved.
Posted Oct 18, 2019 - 09:23 PDT
Identified
Orders for Zalora Gift Card S$25 are failing with our supplier. We are working with our vendor to make this available again.

The affected UTID is U035753.
Posted Oct 14, 2019 - 10:02 PDT
This incident affected: Item.