Item Outage - Planet Sports eGift ₱3000 - 2/14/2020
Incident Report for Tango Card
Resolved
This outage has ended.
Posted Feb 14, 2020 - 14:58 PST
Update
We are continuing to work on a fix for this issue.
Posted Feb 14, 2020 - 11:41 PST
Update
We are continuing to work on a fix for this issue.
Posted Feb 14, 2020 - 11:40 PST
Identified
Planet Sports eGift ₱3000 is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U591025
Posted Feb 14, 2020 - 11:40 PST
This incident affected: Item.