Some recipients who were prompted to complete a tax form were unable to do so

Incident Report for Tango Card

Resolved

This incident has been resolved.
Posted Nov 07, 2025 - 12:15 PST

Investigating

This issue has been resolved. Recipients should now be able to complete the tax form and reward redemption. Some direct follow up with customer/recipients will be coordinated as needed with customer-facing teams.
Posted Nov 07, 2025 - 12:15 PST
This incident affected: Reward Link - Production.