Item Outage - CVS Pharmacy® Select Gift Card $25 - 10/17/19
Incident Report for Tango Card
Resolved
This outage has been resolved.
Posted Oct 18, 2019 - 11:59 PDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 17, 2019 - 05:09 PDT
Identified
We are experiencing an outage on CVS Pharmacy® Select Gift Card $25. More is on order, and we expect to have this back in stock, soon.

The affected UTID is U242036.
Posted Oct 17, 2019 - 05:09 PDT
This incident affected: Item.