Item Outage - Spotify Premium Brazil Virtual Gift Card R$50
Incident Report for Tango Card
Resolved
This outage has been resolved.
Posted Sep 30, 2020 - 16:01 PDT
Identified
Spotify Premium Brazil Virtual Gift Card R$50 is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U967525
Posted Sep 24, 2020 - 12:10 PDT
This incident affected: Item.