Help Center current outage
Incident Report for Tango Card
Resolved
Our partner has posted an update, and we are marking the issue as resolved.
Posted May 11, 2021 - 19:34 PDT
Monitoring
Our partner has taken steps to mitigate, and our Help Center (help.tangocard.com) is back up at this time. We are monitoring and will post another update shortly.
Posted May 11, 2021 - 17:28 PDT
Investigating
Our Help Center (help.tangocard.com) for recipient support is currently experiencing an outage, and we are working with our partners to resolve.
Posted May 11, 2021 - 15:34 PDT
Identified
Our Help Center (help.tangocard.com) for recipient support is currently experiencing an outage, and we are working with our partners to resolve.
Posted May 11, 2021 - 15:34 PDT