Item Outage: Texas Roadhouse eGift Card - 10/17/2019
Incident Report for Tango Card
Resolved
This outage has been resolved.
Posted Oct 25, 2019 - 13:48 PDT
Identified
Texas Roadhouse eGift Card is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U906484
Posted Oct 17, 2019 - 16:43 PDT
This incident affected: Item.