Item Outage - Grab Gift Card S$10
Incident Report for Tango Card
Resolved
This outage is resolved.
Posted Oct 16, 2020 - 11:33 PDT
Identified
Grab Gift Card S$10 is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U893971
Posted Oct 05, 2020 - 11:56 PDT
This incident affected: Item.