Item Outage - The Home Depot® eGift Cards
Incident Report for Tango Card
Resolved
This outage is resolved.
Posted Jul 29, 2020 - 12:57 PDT
Identified
The Home Depot® eGift Cards are currently unavailable. We will post an update when these rewards are once again available.

The affected UTIDS are:
U131864
U231646
U008583
Posted Jul 24, 2020 - 14:40 PDT
This incident affected: Item.