Item Outage - Google Play UK gift codes - 8/20/2019
Incident Report for Tango Card
Resolved
This incident is now resolved.
Posted 27 days ago. Aug 21, 2019 - 09:25 PDT
Identified
Some orders for Google Play UK gift codes are currently failing through our supplier. We will post an update as soon as we learn more.
Posted 27 days ago. Aug 20, 2019 - 15:17 PDT
This incident affected: Item.