Item Outage - Cabela's eGift Cards - 10/16/2019
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted Oct 21, 2019 - 13:36 PDT
Update
Orders for Cabela's eGift Cards $25 and $50 denominations are currently failing through our supplier. We will post an update when this reward is once again available.

The affected UTIDs are U614190 and U816221.
Posted Oct 16, 2019 - 17:02 PDT
Identified
Orders for Cabela's eGift Cards $25 are currently failing though our supplier. We will post an update when this reward is once again available.

The affected UTID is U614190.
Posted Oct 16, 2019 - 15:37 PDT
This incident affected: Item.