Item Outage - NFL® Shop Gift Card $50.00
Incident Report for Tango Card
Resolved
This outage has been resolved.
Posted 7 days ago. Oct 15, 2019 - 11:12 PDT
Identified
We are experiencing and outage on NFL® Shop Gift Card $50.00. The affected UTID is UTID:U734409.

We have more of this item on order.
Posted 25 days ago. Sep 27, 2019 - 09:12 PDT
This incident affected: Item.