Item Outage - Wayfair.com eGift Card $50.00 U055904
Incident Report for Tango Card
Resolved
This outage has ended.
Posted Jul 09, 2019 - 13:18 PDT
Identified
We are experiencing and outage for Wayfair.com eGift Card $50.00. We are working with our vendor to end this outage, as soon as possible.
Posted Jul 09, 2019 - 13:05 PDT
This incident affected: Item.