Item Outage - Whole Foods Market® eGift Card $25 - 9/28/2020
Incident Report for Tango Card
Resolved
This outage is resolved.
Posted Sep 28, 2020 - 13:29 PDT
Identified
Whole Foods Market® eGift Card $25 is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U330530
Posted Sep 28, 2020 - 10:35 PDT
This incident affected: Item.