Item Outage - Shoptime Virtual Gift Card $R50 & $R100
Incident Report for Tango Card
Resolved
These outages have been resolved.
Posted Sep 30, 2020 - 16:02 PDT
Identified
Spotify Premium Brazil Virtual Gift Cards R$50 & $R100 are currently unavailable. We will post an update when these rewards are once again available.

The affected UTIDs are:
U793472
U612097
Posted Sep 24, 2020 - 13:43 PDT
This incident affected: Item.