Item Outage - Royal Caribbean International Gift Cards - 10/12/20
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted Nov 11, 2020 - 16:28 PST
Identified
Royal Caribbean International Gift Cards $250.00 and $500.00 are currently unavailable. We will post an update when these rewards are once again available.

The affected UTIDs are:
U183765
U154671
Posted Oct 12, 2020 - 10:11 PDT
This incident affected: Item.