Item Outage - iTunes Germany eGift Card €15.00 -- UTID: U0797514
Incident Report for Tango Card
Resolved
This outage has ended.
Posted Jul 11, 2019 - 13:05 PDT
Identified
We are experiencing an outage on iTunes Germany eGift Card €15.00 (UTID:U0797514). More is on order, and we expect to have this back in stock, shortly.
Posted Jul 05, 2019 - 08:31 PDT
This incident affected: Item.