Item Outage - Dinero Electrónico Coppel $100 & $200 - 7/29/2020
Incident Report for Tango Card
Resolved
This outage has been resolved.
Posted Jul 31, 2020 - 16:13 PDT
Identified
Dinero Electrónico Coppel $100 & $200 are currently unavailable. We will post an update when these rewards are once again available.

The affected UTIDs are: U565655, U910765
Posted Jul 29, 2020 - 09:22 PDT
This incident affected: Item.