Inactive Item - Sony PlayStation Plus Canada 3mo/12mo Membership - 9/23/2019
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted Nov 19, 2019 - 16:59 PST
Update
We are continuing to work on a fix for this issue.
Posted Sep 23, 2019 - 17:11 PDT
Identified
Sony PlayStation Plus Canada 3 month and 12 month Memberships have been set to inactive and are no longer available for purchase until further notice.

We will post an update as soon as we have more information.
Posted Sep 23, 2019 - 17:03 PDT
This incident affected: Item.