Item Outage - Q8 eGift Card EUR 20 - UTID U209914
Incident Report for Tango Card
Resolved
This outage has ended.
Posted Jul 15, 2019 - 12:05 PDT
Identified
We are experiencing an outage on Q8 eGift Card EUR 20 , UTID U209914. More is on order from our vendor, and we expect to replenish inventory by the end of the week.
Posted Jul 10, 2019 - 12:05 PDT
This incident affected: Item.