Item Outage - Multi-Brand GiftPax eGift Card $25.00
Incident Report for Tango Card
Resolved
This outage has ended.
Posted Feb 06, 2020 - 10:17 PST
Identified
We are experiencing an outage on Multi-Brand GiftPax eGift Card $25.00. We will post an update when this reward is once again available.

The affected UTID is U514692.
Posted Feb 03, 2020 - 15:23 PST
This incident affected: Item.