Item Denomination Change - Google Play USD
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted Oct 23, 2020 - 14:11 PDT
Identified
Google Play (USD) has recently lowered their maximum available denomination. The new current maximum is $200, previous to a maximum of $500. The minimum available to order has remained the same at $5. This change to the maximum denomination is effective immediately.

The affected UTID is: U505722
Posted Aug 18, 2020 - 20:21 PDT
This incident affected: Item.