Item Outage - JCPenney E-Gift Card $5.00 & $10.00
Incident Report for Tango Card
Resolved
This outage has been resolved.
Posted 18 days ago. Oct 04, 2019 - 10:53 PDT
Identified
We are currently out of inventory for JCPenney E-Gift Card $5.00 and $10.00. We will post an update when these rewards are once again available.

The affected UTID's are U333200 & U957067.
Posted 19 days ago. Oct 03, 2019 - 17:34 PDT
This incident affected: Item.