Item Inactivation: MovieChoice online KinoGutschein 10 € - 9/7/2019
Incident Report for Tango Card
Resolved
This item has been set to active, and the outage has ended.
Posted 7 days ago. Sep 09, 2019 - 10:36 PDT
Investigating
We are currently out of inventory for MovieChoice online KinoGutschein 10 € rewards. We have set the item to inactive until we are able to replenish inventory.

The following UTID is affected: U261596
Posted 9 days ago. Sep 07, 2019 - 15:26 PDT
This incident affected: Item.