Inactive Item - Amazon.in Gift Card ₹2500
Incident Report for Tango Card
Resolved
This outage is resolved.
Posted 14 days ago. Sep 03, 2019 - 08:59 PDT
Monitoring
The item, Amazon.in Gift Card ₹2500, has been inactivated, indefinitely. The affected UTID is U478645.
Posted 20 days ago. Aug 27, 2019 - 23:36 PDT
This incident affected: Item.