Planned Outage - Amazon.ca and Amazon.com - 1/15/2020
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted Jan 17, 2020 - 14:46 PST
Identified
Amazon is planning on upgrading their systems on Wednesday, January 15th 2020 between 06:00 – 06:10 UTC.

During these times orders for the following products may fail:

• Amazon.ca
• Amazon.com

If anything changes we will provide updates here.
Posted Jan 13, 2020 - 11:05 PST
This incident affected: Item.