Item Outage: Grab Gift Card S$15 - 8/9/2019
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 13, 2019 - 11:25 PDT
Identified
Orders for Grab Gift Card S$15 rewards are currently failing through our supplier. We will post an update when this reward is once again available.

The following UTID is affected: U352036
Posted about 1 month ago. Aug 09, 2019 - 08:39 PDT
This incident affected: Item.