Item Outage - Q8 eGift Card EUR 10 - UTID U482641
Incident Report for Tango Card
Resolved
This outage is resolved.
Posted about 1 month ago. Aug 14, 2019 - 16:39 PDT
Identified
We are experiencing an outage on Item Outage - Q8 eGift Card EUR 10 - UTID U482641. More is on order, and we expect to have this back in stock, soon.
Posted 2 months ago. Jul 10, 2019 - 14:36 PDT
This incident affected: Item.