Item Outage - HelloFresh - 01/17/20
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted May 28, 2020 - 14:40 PDT
Investigating
HelloFresh Vouchers (All Denominations) are currently unavailable. We will post an update when this reward is once again available.

The affected UTIDs are: U776813, U630228, U460088, U748635
Posted Jan 17, 2020 - 09:13 PST
This incident affected: Item.