Item Outage: Amazon.com - 1/30/2019
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted Jan 31, 2020 - 01:21 PST
Monitoring
Orders are once again successful. We will continue to monitor to ensure there are no additional issues.
Posted Jan 31, 2020 - 00:34 PST
Investigating
Orders for Amazon.com Gift Cards are currently failing. We will post an update when this reward is once again available.

The affected UTIDs are:

U666425
U772684
U045950
U441138
U001214
U974333
U477146
U568987
U978081
U852582
Posted Jan 30, 2020 - 23:59 PST
This incident affected: Item.