ACH funding via Tango Portal
Incident Report for Tango Card
Resolved
This issue has been resolved.
Posted Sep 09, 2024 - 11:17 PDT
Update
Customers cannot add funds to their account via ACH in Tango Portal.

We are investigating this issue and do not currently have an ETA for resolution.

Until it is resolved, customers who wish to fund their account can use a credit card or contact funding@tangocard.com for assistance.

Funding via credit card is working properly. However, customers may need to refresh their browser tab to confirm that the credit card transaction has completed successfully.
Posted Sep 06, 2024 - 22:25 PDT
Investigating
Customers cannot add funds to their account via ACH in Tango Portal.

We are investigating this issue and do not currently have an ETA for resolution.
Posted Sep 06, 2024 - 18:10 PDT
This incident affected: Rewards Genius - Production.