Global choice link exchange rates are in error

Incident Report for Tango Card

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 16:13 PST

Identified

The issue has been identified, and a fix is being implemented.
Posted Dec 03, 2025 - 15:24 PST

Investigating

We are currently investigating exchange rate issues for Global Choice Links.
Posted Dec 03, 2025 - 15:15 PST
This incident affected: Reward Link - Production.