Item Outage -Amazon Pay Gift Card India ₹25
Incident Report for Tango Card
Resolved
This outage has ended.
Posted about 7 hours ago. Sep 16, 2019 - 15:41 PDT
Monitoring
We are experiencing an outage on Amazon Pay Gift Card India ₹25. The affected UTID is UTID:U128141.

More is on order, and we expect to have this in stock, again, early next week.
Posted 5 days ago. Sep 11, 2019 - 13:04 PDT
This incident affected: Item.