Item Outage - Foot Locker $25 Email Gift Card - 8/21/2019
Incident Report for Tango Card
Resolved
This outage is now resolved.
Posted 25 days ago. Aug 22, 2019 - 12:52 PDT
Identified
Foot Locker $25 Email Gift Cards are currently out of stock through our supplier. We will post an update as soon as the item becomes available again.
Posted 26 days ago. Aug 21, 2019 - 14:48 PDT
This incident affected: Item.