Item Outage - Macy's E-Gift Card $10.00
Incident Report for Tango Card
Resolved
This outage has ended.
Posted 14 days ago. Oct 08, 2019 - 10:54 PDT
Identified
Identified
We are currently out of inventory for Macy's E-Gift Card $10.00. We will post an update when this reward is once again available.

The affected UTID is UTID:U814874.
Posted 15 days ago. Oct 07, 2019 - 18:32 PDT
This incident affected: Item.