Item Outage: iTunes Canada $10 - 10/2/19
Incident Report for Tango Card
Resolved
This outage has been resolved.
Posted 8 days ago. Oct 14, 2019 - 11:48 PDT
Identified
We are currently out of inventory for iTunes Canada $10. We will post an update when this reward is once again available.

The affected UTID is U323615.
Posted 20 days ago. Oct 02, 2019 - 08:52 PDT
This incident affected: Item.