Item Outage - Grab Gift Card S$15 - 10/4/2019
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted 15 days ago. Oct 07, 2019 - 09:37 PDT
Identified
Orders for Grab Gift Cards S$15 are currently failing though our supplier. We will post an update when this reward is once again available.

The affected UTID is U352036.
Posted 18 days ago. Oct 04, 2019 - 09:28 PDT
This incident affected: Item.