Item Outage - The Home Depot eGift Card - 8/28/2019
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted 18 days ago. Aug 29, 2019 - 14:22 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 18 days ago. Aug 29, 2019 - 11:11 PDT
Investigating
Some orders for The Home Depot eGift Cards are currently failing through our supplier. The issue is being investigated, we will post updates as we learn more.
Posted 19 days ago. Aug 29, 2019 - 09:56 PDT
This incident affected: Item.