Inactive item: Charming Charlie eGift Cards - 7/17/2019
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted 11 days ago. Sep 05, 2019 - 15:25 PDT
Identified
Charming Charlie eGift Cards have been set to inactive and are no longer available for purchase.
Posted 2 months ago. Jul 17, 2019 - 13:52 PDT
This incident affected: Item.