Giftcard: Amazon - Currencies: USD, Mexico, and Canada are not issuing

Incident Report for Tango Card

Resolved

It has been resolved.
Posted Oct 20, 2025 - 07:30 PDT

Monitoring

The issue has been addressed and will continue to monitor.
Posted Oct 20, 2025 - 03:02 PDT

Investigating

We are currently investigating the issue.
Posted Oct 20, 2025 - 02:45 PDT
This incident affected: RaaS API v2 - Production, Rewards Genius - Production, and Landing Page.