Item Deprecation - Al-Futtaim Retail Asia Gift Cards (SGD) - 9/29/2020
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted Nov 21, 2020 - 12:50 PST
Identified
Effective today, September 29th, Al-Futtaim Retail Asia Gift Cards (SGD) will no longer be available through Tango Card.
Tango Card will continue to offer gift cards from retailers in Singapore, including: Best Denki, Cold Storage, Giant, Tangs, Zalora, and others.

Impacted UTID(s): U507729, U223630, U628216, U913209
Posted Sep 29, 2020 - 08:51 PDT
This incident affected: Item.