Item Outage: Flipkart Gift Card ₹100 - 10/1/209
Incident Report for Tango Card
Resolved
This outage has ended.
Posted 21 days ago. Oct 01, 2019 - 09:02 PDT
Identified
We are currently out of inventory for Flipkart Gift Card ₹100. We will post an update when this reward is once again available.

The affected UTID is: U700436
Posted 21 days ago. Oct 01, 2019 - 01:26 PDT
This incident affected: Item.