Item Outage - GiftPax eGift Card $10.00
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted 12 days ago. Sep 04, 2019 - 14:40 PDT
Update
We are continuing to monitor for any further issues.
Posted 18 days ago. Aug 29, 2019 - 19:21 PDT
Monitoring
We are currently out of GiftPax eGift Card $25.00. More is on order, and we are working to get this in stock, soon. The affected UTID is U452604.
Posted 18 days ago. Aug 29, 2019 - 19:21 PDT
This incident affected: Item.